Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:requests

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Incorrect Authorization in Jenkins requests-plugin

    CVE-2022-34782 · GHSA-6xhf-xx3j-75f5

    Affected
    • Maven org.jenkins-ci.plugins:requests <= 2.2.16
    Fixed in
    2.2.17· Vendor fix available
    Issue
    An incorrect permission check in Jenkins requests-plugin Plugin 2.2.16 and earlier allows attackers with Overall/Read permission to view the list of pending requests. requests-plugin Plugin 2.2.17 requires Overall/Administer permission to view the list of pending requests. This is basically the same vulnerability as SECURITY-1995, whose fix was ineffective. requests-plugin Plugin 2.2.17 requires Overall/Administer permission to view the list of pending requests.

    Recommended action: Upgrade to 2.2.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Missing permission check in Jenkins requests-plugin Plugin allows viewing pending requests

    CVE-2021-21674 · GHSA-c4c3-3cgh-vvrh

    Affected
    • Maven org.jenkins-ci.plugins:requests <= 2.2.6
    Fixed in
    2.2.7· Vendor fix available
    Issue
    Jenkins requests-plugin Plugin 2.2.6 and earlier does not perform a permission check in an HTTP endpoint. This allows attackers with Overall/Read permission to view the list of pending requests. Jenkins requests-plugin Plugin 2.2.7 requires Overall/Administer permission to view the list of pending requests. The previous sentence originally stated that Overall/Read permission was newly required. This statement was incorrect and has been fixed on 2021-07-05.

    Recommended action: Upgrade to 2.2.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.5MavenPublished

    CSRF vulnerabilities in Jenkins requests-plugin Plugin

    CVE-2021-21675 · GHSA-5frh-wx6v-8m2r

    Affected
    • Maven org.jenkins-ci.plugins:requests <= 2.2.12
    Fixed in
    2.2.13· Vendor fix available
    Issue
    Jenkins requests-plugin Plugin 2.2.12 and earlier does not require POST requests to request and apply changes, resulting in cross-site request forgery (CSRF) vulnerabilities. These vulnerabilities allow attackers to create requests and/or have administrators apply pending requests, like renaming or deleting jobs, deleting builds, etc. Jenkins requests-plugin Plugin 2.2.13 requires POST requests for the affected HTTP endpoints. This was partially fixed in requests-plugin Plugin 2.2.8 to require POST requests for some of the affected HTTP endpoints, but the endpoint allowing administrators to apply pending requests remained unprotected until 2.2.13.

    Recommended action: Upgrade to 2.2.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 4.3MavenPublished

    Missing permission check in Jenkins requests-plugin Plugin allows sending emails

    CVE-2021-21676 · GHSA-w3gm-vv58-wr55

    Affected
    • Maven org.jenkins-ci.plugins:requests <= 2.2.7
    Fixed in
    2.2.8· Vendor fix available
    Issue
    Jenkins requests-plugin Plugin 2.2.7 and earlier does not perform a permission check in an HTTP endpoint. This allows attackers with Overall/Read permission to send test emails to an attacker-specified email address. Jenkins requests-plugin Plugin 2.2.8 requires Overall/Administer permission to send test emails.

    Recommended action: Upgrade to 2.2.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →