High, CVSS 8.8MavenPublished
RCE vulnerability in RadarGun Plugin
CVE-2020-2123 · GHSA-723p-9rcj-xv8j
- Affected
- Maven org.jenkins-ci.plugins:radargun < 1.8
- Fixed in
- 1.8· Vendor fix available
- Issue
- RadarGun Plugin 1.7 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution vulnerability exploitable by users able to configure RadarGun Plugin’s build step. RadarGun Plugin 1.8 configures its YAML parser to only instantiate safe types.
Recommended action: Upgrade to 1.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.