Medium, CVSS 4.2MavenPublished
Jenkins Publisher Over CIFS Plugin confused deputy vulnerability
CVE-2018-1999038 · GHSA-rf7h-9m85-535v
- Affected
- Maven org.jenkins-ci.plugins:publish-over-cifs <= 0.10
- Fixed in
- 0.11· Vendor fix available
- Issue
- A confused deputy vulnerability exists in Jenkins Publisher Over CIFS Plugin 0.10 and earlier in CifsPublisherPluginDescriptor.java that allows attackers to have Jenkins connect to an attacker specified CIFS server with attacker specified credentials. Additionally, this form validation method did not require POST requests, resulting in a CSRF vulnerability. As of version 0.11, this form validation method requires POST requests and Overall/Administer permissions.
Recommended action: Upgrade to 0.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.