Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:plot

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1MavenPublished

    Jenkins Plot Plugin XML External Entity Reference vulnerability

    CVE-2022-46682 · GHSA-wgpp-g6v9-7hxp

    Affected
    • Maven org.jenkins-ci.plugins:plot < 2.1.12
    Fixed in
    2.1.12· Vendor fix available
    Issue
    Jenkins Plot Plugin 2.1.11 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. This allows attackers able to control XML input files for the 'Plot build data' build step to have Jenkins parse a crafted file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery. Plot Plugin 2.1.12 disables external entity resolution for its XML parser.

    Recommended action: Upgrade to 2.1.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.0MavenPublished

    Cross-site Scripting in Jenkins Plot Plugin

    CVE-2022-34783 · GHSA-hpf7-mmqw-g6vq

    Affected
    • Maven org.jenkins-ci.plugins:plot < 2.1.11
    Fixed in
    2.1.11· Vendor fix available
    Issue
    Jenkins Plot Plugin 2.1.10 and earlier does not escape plot descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

    Recommended action: Upgrade to 2.1.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →