Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:p4

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    CSRF vulnerability in Jenkins P4 Plugin

    CVE-2020-2141 · GHSA-rjjq-63c7-8724

    Affected
    • Maven org.jenkins-ci.plugins:p4 < 1.10.11
    Fixed in
    1.10.11· Vendor fix available
    Issue
    A cross-site request forgery vulnerability in Jenkins P4 Plugin 1.10.10 and earlier allows attackers to trigger builds or add a labels in Perforce.

    Recommended action: Upgrade to 1.10.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Missing permission checks in Jenkins P4 Plugin

    CVE-2020-2142 · GHSA-f9v6-p7hp-c3qx

    Affected
    • Maven org.jenkins-ci.plugins:p4 < 1.10.11
    Fixed in
    1.10.11· Vendor fix available
    Issue
    A missing permission check in Jenkins P4 Plugin 1.10.10 and earlier allows attackers with Overall/Read permission to trigger builds or add labels in the Perforce repository. P4 Plugin 1.10.11 appropriate user permissions for the affected HTTP endpoints.

    Recommended action: Upgrade to 1.10.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.1MavenPublished

    Cross-Site Request Forgery in Jenkins P4 Plugin

    CVE-2021-21655 · GHSA-3rj3-qp2j-4fj2

    Affected
    • Maven org.jenkins-ci.plugins:p4 < 1.11.5
    Fixed in
    1.11.5· Vendor fix available
    Issue
    A cross-site request forgery (CSRF) vulnerability in Jenkins P4 Plugin 1.11.4 and earlier allows attackers to connect to an attacker-specified Perforce server using attacker-specified username and password. Jenkins P4 Plugin 1.11.5 requires POST requests for the affected HTTP endpoints.

    Recommended action: Upgrade to 1.11.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 4.3MavenPublished

    Missing Authorization in Jenkins P4 plugin

    CVE-2021-21654 · GHSA-h6qv-f5gf-8gcf

    Affected
    • Maven org.jenkins-ci.plugins:p4 <= 1.11.4
    Fixed in
    1.11.5· Vendor fix available
    Issue
    Jenkins P4 Plugin 1.11.4 and earlier does not perform permission checks in multiple HTTP endpoints, allowing attackers with Overall/Read permission to connect to an attacker-specified Perforce server using attacker-specified username and password. Jenkins P4 Plugin 1.11.5 requires Overall/Administer for the affected HTTP endpoints.

    Recommended action: Upgrade to 1.11.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →