Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:mask-passwords

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    Insertion of Sensitive Information into Log File in Jenkins Mask Passwords Plugin

    CVE-2019-10370 · GHSA-gp67-c7j2-2qg2

    Affected
    • Maven org.jenkins-ci.plugins:mask-passwords <= 2.12.0
    Fixed in
    2.13.0· Vendor fix available
    Issue
    Jenkins Mask Passwords Plugin 2.12.0 and earlier transmits globally configured passwords in plain text as part of the configuration form, potentially resulting in their exposure.

    Recommended action: Upgrade to 2.13.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4MavenPublished

    Stored Cross-site Scripting in Jenkins Mask Passwords Plugin

    CVE-2022-29043 · GHSA-pjm3-f4vh-3h3h

    Affected
    • Maven org.jenkins-ci.plugins:mask-passwords < 3.1
    Fixed in
    3.1· Vendor fix available
    Issue
    Jenkins Mask Passwords Plugin 3.0 and earlier does not escape the name and description of Non-Stored Password parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Exploitation of this vulnerability requires that parameters are listed on another page, like the \"Build With Parameters\" and \"Parameters\" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the \"Build With Parameters\" and \"Parameters\" pages since 2.44 and LTS 2.32.2 as part of the SECURITY-353 / CVE-2017-2601 fix.

    Recommended action: Upgrade to 3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →