Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:log-parser

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Jenkins Log Parser Plugin vulnerable to Cross-site Scripting

    CVE-2019-10410 · GHSA-xqqw-cqjp-52xm

    Affected
    • Maven org.jenkins-ci.plugins:log-parser < 2.1
    Fixed in
    2.1· Vendor fix available
    Issue
    Log Parser Plugin did not escape an error message shown when log parsing patterns are invalid. This resulted in a persisted cross-site scripting vulnerability exploitable by attackers able to control the log parsing rules configuration, typically users with Job/Configure permission. Jenkins applies the missing escaping by default since 2.146 and LTS 2.138.2, so newer Jenkins releases are not affected by this vulnerability. Log Parser Plugin version 2.1 escapes all variables displayed in its views.

    Recommended action: Upgrade to 2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →