Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:liquibase-runner

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Stored XSS vulnerability in Jenkins Liquibase Runner Plugin

    CVE-2020-2283 · GHSA-9hg7-xmf8-jxf9

    Affected
    • Maven org.jenkins-ci.plugins:liquibase-runner <= 1.4.5
    Fixed in
    1.4.6· Vendor fix available
    Issue
    Liquibase Runner Plugin 1.4.5 and earlier does not escape changeset contents when showing them on the build page. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide Liquibase changesets evaluated by the plugin. Liquibase Runner Plugin 1.4.7 no longer supports evaluating changesets.

    Recommended action: Upgrade to 1.4.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.1MavenPublished

    XXE vulnerability in Jenkins Liquibase Runner Plugin

    CVE-2020-2284 · GHSA-xx7g-f287-f9fq

    Affected
    • Maven org.jenkins-ci.plugins:liquibase-runner <= 1.4.5
    Fixed in
    1.4.7· Vendor fix available
    Issue
    Jenkins Liquibase Runner Plugin 1.4.5 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. This allows attackers able to provide Liquibase changesets evaluated by the plugin to have Jenkins parse a crafted XML file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery. Jenkins Liquibase Runner Plugin 1.4.7 no longer parses Liquibase changesets.

    Recommended action: Upgrade to 1.4.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 4.3MavenPublished

    Missing permission check in Jenkins Liquibase Runner Plugin allows enumerating credentials IDs

    CVE-2020-2285 · GHSA-44cm-p9q7-rr3p

    Affected
    • Maven org.jenkins-ci.plugins:liquibase-runner <= 1.4.7
    Fixed in
    1.4.8· Vendor fix available
    Issue
    Liquibase Runner Plugin 1.4.7 and earlier does not perform a permission check in an HTTP endpoint. This allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of credentials IDs in Liquibase Runner Plugin 1.4.8 requires the appropriate permissions.

    Recommended action: Upgrade to 1.4.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.8MavenPublished

    Liquibase Runner Plugin allows users to load arbitrary Java code into controller JVM

    CVE-2018-1000146 · GHSA-3hvc-xwjp-xr8m

    Affected
    • Maven org.jenkins-ci.plugins:liquibase-runner < 1.4.3
    Fixed in
    1.4.3· Vendor fix available
    Issue
    An arbitrary code execution vulnerability exists in Liquibase Runner Plugin version 1.3.0 and older that allows an attacker with permission to configure jobs to load and execute arbitrary code on the Jenkins master JVM.

    Recommended action: Upgrade to 1.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →