Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:libvirt-slave

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8MavenPublished

    CSRF vulnerability in Jenkins Libvirt Agents Plugin

    CVE-2021-21627 · GHSA-mm5c-7mpr-99fm

    Affected
    • Maven org.jenkins-ci.plugins:libvirt-slave <= 1.9.0
    Fixed in
    1.9.1· Vendor fix available
    Issue
    Jenkins Libvirt Agents Plugin 1.9.0 and earlier does not require POST requests for a form submission endpoint, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to stop hypervisor domains. Jenkins Libvirt Agents Plugin 1.9.1 requires POST requests for the affected HTTP endpoint.

    Recommended action: Upgrade to 1.9.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.5MavenPublished

    Jenkins Libvirt Slaves Plugin vlnerable to Incorrect Default Permissions

    CVE-2019-10472 · GHSA-m36j-f2hf-qgj2

    Affected
    • Maven org.jenkins-ci.plugins:libvirt-slave < 1.8.6
    Fixed in
    1.8.6· Vendor fix available
    Issue
    A missing permission check in Jenkins Libvirt Slaves Plugin allows attackers with Overall/Read permission to connect to an attacker-specified SSH server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

    Recommended action: Upgrade to 1.8.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.8MavenPublished

    Jenkins Libvirt Slaves Plugin vlnerable to Cross-Site Request Forgery

    CVE-2019-10471 · GHSA-m295-m3x4-3mmc

    Affected
    • Maven org.jenkins-ci.plugins:libvirt-slave < 1.8.6
    Fixed in
    1.8.6· Vendor fix available
    Issue
    A cross-site request forgery vulnerability in Jenkins Libvirt Slaves Plugin allows attackers to connect to an attacker-specified SSH server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

    Recommended action: Upgrade to 1.8.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 4.3MavenPublished

    Jenkins Libvirt Slaves Plugin vlnerable to Credential Enumeration

    CVE-2019-10473 · GHSA-8j3m-j6x6-cp5v

    Affected
    • Maven org.jenkins-ci.plugins:libvirt-slave < 1.8.6
    Fixed in
    1.8.6· Vendor fix available
    Issue
    A missing permission check in Jenkins Libvirt Slaves Plugin in form-related methods allowed users with Overall/Read access to enumerate credentials ID of credentials stored in Jenkins.

    Recommended action: Upgrade to 1.8.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →