Medium, CVSS 6.1MavenPublished
Cross-site scripting in Jenkins Kiuwan Plugin
CVE-2021-21666 · GHSA-8h77-3xwr-hqhh
- Affected
- Maven org.jenkins-ci.plugins:kiuwanJenkinsPlugin < 1.6.1
- Fixed in
- 1.6.1· Vendor fix available
- Issue
- Jenkins Kiuwan Plugin 1.6.0 and earlier does not escape query parameters in an error message for a form validation endpoint, resulting in a reflected cross-site scripting (XSS) vulnerability. Only older releases of Jenkins are affected by this vulnerability. Jenkins 2.275 and newer, LTS 2.263.2 and newer include a protection preventing this from being exploitable. Jenkins Kiuwan Plugin 1.6.1 escapes affected parts of the error message in the form validation endpoint.
Recommended action: Upgrade to 1.6.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.