Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:kanboard

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Jenkins Kanboard Plugin vulnerable to Server-side request forgery (SSRF)

    CVE-2019-1003020 · GHSA-278v-j3cr-jv2x

    Affected
    • Maven org.jenkins-ci.plugins:kanboard <= 1.5.10
    Fixed in
    1.5.11· Vendor fix available
    Issue
    A server-side request forgery vulnerability exists in Jenkins Kanboard Plugin 1.5.10 and earlier in KanboardGlobalConfiguration.java that allows attackers with Overall/Read permission to submit a GET request to an attacker-specified URL.

    Recommended action: Upgrade to 1.5.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →