Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:jira

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Jenkins Jira Plugin vulnerable to exposure of system-scoped credentials

    CVE-2023-49653 · GHSA-qmhq-876f-cr65

    Affected
    • Maven org.jenkins-ci.plugins:jira < 3.12
    Fixed in
    3.12· Vendor fix available
    Issue
    Jenkins Jira Plugin 3.11 and earlier does not set the appropriate context for credentials lookup, allowing the use of system-scoped credentials otherwise reserved for the global configuration. This allows attackers with Item/Configure permission to access and capture credentials they are not entitled to. Jira Plugin 3.12 defines the appropriate context for credentials lookup.

    Recommended action: Upgrade to 3.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.5MavenPublished

    Jenkins JIRA Plugin allows users to select and use credentials with System scope

    CVE-2019-16541 · GHSA-98m4-m2c3-qxgq

    Affected
    • Maven org.jenkins-ci.plugins:jira <= 3.0.10
    Fixed in
    3.0.11· Vendor fix available
    Issue
    Jenkins JIRA Plugin 3.0.10 and earlier does not declare the correct (folder) scope for per-folder Jira site definitions, allowing users to select and use credentials with System scope. Jira Plugin 3.0.11 defines the appropriate folder context for credential lookup. As a side effect, existing per-folder Jira sites may lose access to already configured System-scoped credentials, as if no credential was specified in the first place.

    Recommended action: Upgrade to 3.0.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 4.2MavenPublished

    Jenkins Jira Plugin Incorrect Authorization vulnerability

    CVE-2018-1000412 · GHSA-fpg6-xqj4-j7wf

    Affected
    • Maven org.jenkins-ci.plugins:jira <= 3.0.1
    Fixed in
    3.0.2· Vendor fix available
    Issue
    An improper authorization vulnerability exists in Jenkins Jira Plugin 3.0.1 and earlier in JiraSite.java that allows attackers with Overall/Read access to have Jenkins connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. In version 3.0.2, this form validation method requires POST requests and Overall/Administer (for globally defined sites) or Item/Configure permissions (for sites defined for a folder).

    Recommended action: Upgrade to 3.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.4MavenPublished

    Stored Cross-site Scripting vulnerability in Jenkins Jira Plugin

    CVE-2022-29041 · GHSA-m3p3-2gp6-ghq8

    Affected
    • Maven org.jenkins-ci.plugins:jira >= 3.7.0, < 3.7.1; < 3.6.1
    Fixed in
    3.7.13.6.1· Vendor fix available
    Issue
    Jenkins Jira Plugin 3.7 and earlier, except 3.6.1, does not escape the name and description of Jira Issue and Jira Release Version parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Exploitation of this vulnerability requires that parameters are listed on another page, like the \"Build With Parameters\" and \"Parameters\" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the \"Build With Parameters\" and \"Parameters\" pages since 2.44 and LTS 2.32.2 as part of the SECURITY-353 / CVE-2017-2601 fix.

    Recommended action: Upgrade to 3.7.1 or 3.6.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →