Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:jclouds-jenkins

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.2MavenPublished

    Jenkins JClouds Plugin cross-site request forgery vulnerability

    CVE-2019-10368 · GHSA-87hx-q65g-r35x

    Affected
    • Maven org.jenkins-ci.plugins:jclouds-jenkins <= 2.14
    Fixed in
    2.15· Vendor fix available
    Issue
    Jenkins JClouds Plugin did not perform permission checks on a method implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, this form validation method did not require POST requests, resulting in a cross-site request forgery vulnerability. This form validation method now requires POST requests and Overall/Administer permission.

    Recommended action: Upgrade to 2.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.2MavenPublished

    Jenkins JClouds Plugin missing permission check

    CVE-2019-10369 · GHSA-7wxc-7qrg-rg6w

    Affected
    • Maven org.jenkins-ci.plugins:jclouds-jenkins <= 2.14
    Fixed in
    2.15· Vendor fix available
    Issue
    Jenkins JClouds Plugin did not perform permission checks on a method implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, this form validation method did not require POST requests, resulting in a cross-site request forgery vulnerability. This form validation method now requires POST requests and Overall/Administer permission.

    Recommended action: Upgrade to 2.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →