Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:jacoco

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.0MavenPublished

    Jenkins JaCoCo Plugin vulnerable to Stored Cross-site Scripting

    CVE-2023-28669 · GHSA-xj29-gfww-j67g

    Affected
    • Maven org.jenkins-ci.plugins:jacoco < 3.3.2.1
    Fixed in
    3.3.2.1· Vendor fix available
    Issue
    Jenkins JaCoCo Plugin 3.3.2 and earlier does not escape class and method names shown on the UI, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control input files for the 'Record JaCoCo coverage report' post-build action. Version 3.3.2.1 escapes class and method names shown on the UI.

    Recommended action: Upgrade to 3.3.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →