Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:icescrum

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Jenkins iceScrum Plugin vulnerable to Missing Authorization

    CVE-2019-10442 · GHSA-h5cx-w235-58hm

    Affected
    • Maven org.jenkins-ci.plugins:icescrum < 1.1.6
    Fixed in
    1.1.6· Vendor fix available
    Issue
    A missing permission check in Jenkins iceScrum Plugin prior to version 1.1.6 allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials. This issue is patched in version 1.1.6

    Recommended action: Upgrade to 1.1.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8MavenPublished

    Jenkins iceScrum Plugin stores credentials in Cleartext

    CVE-2019-10443 · GHSA-362p-56c9-q273

    Affected
    • Maven org.jenkins-ci.plugins:icescrum < 1.1.5
    Fixed in
    1.1.5· Vendor fix available
    Issue
    Jenkins iceScrum Plugin 1.1.4 and earlier stored credentials unencrypted in job config.xml files on the Jenkins master where they could be viewed by users with Extended Read permission, or access to the master file system.

    Recommended action: Upgrade to 1.1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 4.3MavenPublished

    Jenkins iceScrum Plugin vulnerable to Cross-site Request Forgery

    CVE-2019-10441 · GHSA-rxvx-9wg5-qpww

    Affected
    • Maven org.jenkins-ci.plugins:icescrum < 1.1.6
    Fixed in
    1.1.6· Vendor fix available
    Issue
    A cross-site request forgery vulnerability in Jenkins iceScrum Plugin prior to version 1.1.6 allows attackers to connect to an attacker-specified URL using attacker-specified credentials. This issue is patched in version 1.1.6

    Recommended action: Upgrade to 1.1.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →