Medium, CVSS 6.5MavenPublished
Improper Limitation of a Pathname to a Restricted Directory in Jenkins Google OAuth Credentials Plugin
CVE-2019-10436 · GHSA-8qh4-fghr-6fxg
- Affected
- Maven org.jenkins-ci.plugins:google-oauth-plugin <= 0.9
- Fixed in
- 0.10· Vendor fix available
- Issue
- An arbitrary file read vulnerability in Jenkins Google OAuth Credentials Plugin 0.9 and earlier allowed attackers able to configure jobs and credentials in Jenkins to obtain the contents of any file on the Jenkins master.
Recommended action: Upgrade to 0.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.