Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:global-build-stats

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Jenkins global-build-stats Plugin missing permission check can result in graph IDs being enumerated

    CVE-2025-58459 · GHSA-gm8g-fh49-qq6v

    Affected
    • Maven org.jenkins-ci.plugins:global-build-stats < 347.v32a
    Fixed in
    347.v32a· Vendor fix available
    Issue
    Jenkins global-build-stats Plugin 322.v22f4db18e2dd and earlier does not perform permission checks in its REST API endpoints, allowing attackers with Overall/Read permission to enumerate graph IDs. This has been patched in version 347.v32aeb0493c4f.

    Recommended action: Upgrade to 347.v32a (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1MavenPublished

    Cross-Site Request Forgery (CSRF) vulnerability in Jenkins global-build-stats plugin

    CVE-2017-1000389 · GHSA-gw8g-hh47-q4gw

    Affected
    • Maven org.jenkins-ci.plugins:global-build-stats <= 1.4
    Fixed in
    1.5· Vendor fix available
    Issue
    Some URLs provided by Jenkins global-build-stats plugin version 1.4 and earlier returned a JSON response that contained request parameters. These responses had the Content Type: text/html, so could have been interpreted as HTML by clients, resulting in a potential reflected cross-site scripting vulnerability. Additionally, some URLs provided by global-build-stats plugin that modify data did not require POST requests to be sent, resulting in a potential cross-site request forgery vulnerability.

    Recommended action: Upgrade to 1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →