Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:gitlab-plugin

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Incorrect permission check in Jenkins GitLab Plugin allows enumerating credentials IDs

    CVE-2025-24397 · GHSA-xhgq-h98j-859v

    Affected
    • Maven org.jenkins-ci.plugins:gitlab-plugin < 1.9.7
    Fixed in
    1.9.7· Vendor fix available
    Issue
    The Jenkins GitLab Plugin 1.9.6 and earlier does not correctly perform a permission check in an HTTP endpoint. This allows attackers with global Item/Configure permission (while lacking Item/Configure permission on any particular job) to enumerate credential IDs of GitLab API token credentials and Secret text credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of credential IDs in GitLab Plugin 1.9.7 requires Overall/Administer permission.

    Recommended action: Upgrade to 1.9.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Low, CVSS 3.7MavenPublished

    Non-constant time webhook token comparison in Jenkins GitLab Plugin

    CVE-2022-43411 · GHSA-f9f9-4r63-4qcc

    Affected
    • Maven org.jenkins-ci.plugins:gitlab-plugin <= 1.5.35
    Fixed in
    1.5.36· Vendor fix available
    Issue
    GitLab Plugin 1.5.35 and earlier does not use a constant-time comparison when checking whether the provided and expected webhook token are equal. This could potentially allow attackers to use statistical methods to obtain a valid webhook token. GitLab Plugin 1.5.36 uses a constant-time comparison when validating the webhook token.

    Recommended action: Upgrade to 1.5.36 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.0MavenPublished

    Cross-site Scripting in Jenkins GitLab Plugin

    CVE-2022-34777 · GHSA-f655-xhvm-cwp4

    Affected
    • Maven org.jenkins-ci.plugins:gitlab-plugin <= 1.5.34
    Fixed in
    1.5.35· Vendor fix available
    Issue
    Jenkins GitLab Plugin 1.5.34 and earlier does not escape multiple fields inserted into the description of webhook-triggered builds, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. GitLab Plugin 1.5.35 does not show user-provided fields in the build cause of webhook-triggered builds. GitLab Plugin 1.5.35 does not show user-provided fields in the build cause of webhook-triggered builds.

    Recommended action: Upgrade to 1.5.35 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.8MavenPublished

    Jenkins GitLab Plugin missing permission checks

    CVE-2019-10301 · GHSA-923w-9p3x-hmgw

    Affected
    • Maven org.jenkins-ci.plugins:gitlab-plugin <= 1.5.11
    Fixed in
    1.5.12· Vendor fix available
    Issue
    Jenkins GitLab Plugin did not perform permission checks on a method implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, this form validation method did not require POST requests, resulting in a cross-site request forgery vulnerability. This form validation method now requires POST requests and Overall/Administer permissions.

    Recommended action: Upgrade to 1.5.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 8.0MavenPublished

    Jenkins GitLab Plugin Cross-Site Request Forgery vulnerability

    CVE-2019-10300 · GHSA-j365-62px-vjjv

    Affected
    • Maven org.jenkins-ci.plugins:gitlab-plugin <= 1.5.11
    Fixed in
    1.5.12· Vendor fix available
    Issue
    Jenkins GitLab Plugin did not perform permission checks on a method implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, this form validation method did not require POST requests, resulting in a cross-site request forgery vulnerability. This form validation method now requires POST requests and Overall/Administer permissions.

    Recommended action: Upgrade to 1.5.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 4.3MavenPublished

    Missing permission check in Jenkins GitLab Plugin

    CVE-2022-30955 · GHSA-5phj-qv74-pv4w

    Affected
    • Maven org.jenkins-ci.plugins:gitlab-plugin < 1.5.32
    Fixed in
    1.5.32· Vendor fix available
    Issue
    Jenkins GitLab Plugin 1.5.31 and earlier does not perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. An enumeration of credentials IDs in GitLab Plugin 1.5.32 requires the appropriate permissions.

    Recommended action: Upgrade to 1.5.32 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →