Medium, CVSS 4.3MavenPublished
Jenkins GitHub Integration Plugin has a cross-site request forgery (CSRF) vulnerability
CVE-2026-48925 · GHSA-rf8w-7c3g-7h3g
- Affected
- Maven org.jenkins-ci.plugins:github-integration-parent <= 0.7.3
- Fixed in
- 0.7.4· Vendor fix available
- Issue
- Jenkins GitHub Integration Plugin 0.7.3 and earlier does not require POST requests for an HTTP endpoint, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to trigger a build for a pull request. GitHub Integration Plugin 0.7.4 requires POST requests for the affected HTTP endpoint.
Recommended action: Upgrade to 0.7.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.