Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:fortify-on-demand-uploader

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Missing permission checks in Jenkins Fortify on Demand Plugin

    CVE-2020-2204 · GHSA-fhmf-xf2q-4m8p

    Affected
    • Maven org.jenkins-ci.plugins:fortify-on-demand-uploader <= 5.0.1
    Fixed in
    6.0.1· Vendor fix available
    Issue
    A missing permission check in Jenkins Fortify on Demand Plugin 5.0.1 and earlier allows attackers with Overall/Read permission to connect to the globally configured Fortify on Demand endpoint using attacker-specified credentials IDs. This form validation method requires appropriate permission in Fortify on Demand Plugin 6.0.1.

    Recommended action: Upgrade to 6.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4MavenPublished

    CSRF vulnerability in Jenkins Fortify on Demand Plugin

    CVE-2020-2203 · GHSA-p364-xfp2-f9rr

    Affected
    • Maven org.jenkins-ci.plugins:fortify-on-demand-uploader <= 5.0.1
    Fixed in
    6.0.0· Vendor fix available
    Issue
    A cross-site request forgery vulnerability in Jenkins Fortify on Demand Plugin 5.0.1 and earlier allows attackers to connect to the globally configured Fortify on Demand endpoint using attacker-specified credentials IDs. This form validation method requires appropriate permission in Fortify on Demand Plugin 6.0.0.

    Recommended action: Upgrade to 6.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 4.3MavenPublished

    Users with Overall/Read access could enumerate credentials IDs in Jenkins Fortify on Demand Plugin

    CVE-2020-2202 · GHSA-fph2-fwjq-prjf

    Affected
    • Maven org.jenkins-ci.plugins:fortify-on-demand-uploader <= 6.0.0
    Fixed in
    6.0.1· Vendor fix available
    Issue
    Fortify on Demand Plugin provides a list of applicable credentials IDs to allow users configuring the plugin to select the one to use. This functionality does not correctly check permissions in Fortify on Demand Plugin 6.0.0 and earlier, allowing any user with Overall/Read permission to get a list of valid credentials IDs. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of credentials IDs in Fortify on Demand Plugin 6.0.1 now requires the appropriate permissions.

    Recommended action: Upgrade to 6.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 4.3MavenPublished

    Jenkins Fortify on Demand Plugin stores credentials in plain text

    CVE-2019-10449 · GHSA-hhhh-69qp-5p2v

    Affected
    • Maven org.jenkins-ci.plugins:fortify-on-demand-uploader <= 4.0.1
    Fixed in
    5.0.0· Vendor fix available
    Issue
    Jenkins Fortify on Demand Plugin stores credentials unencrypted in job config.xml files on the Jenkins controller. These credentials can be viewed by users with Extended Read permission or access to the Jenkins controller file system.

    Recommended action: Upgrade to 5.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 6.5MavenPublished

    Jenkins Fortify on Demand Uploader Plugin CSRF vulnerability

    CVE-2019-1003046 · GHSA-7jcx-j6gv-m4hf

    Affected
    • Maven org.jenkins-ci.plugins:fortify-on-demand-uploader < 3.0.11
    Fixed in
    3.0.11· Vendor fix available
    Issue
    A cross-site request forgery vulnerability in Jenkins Fortify on Demand Uploader Plugin 3.0.10 and earlier allows attackers to initiate a connection to an attacker-specified server.

    Recommended action: Upgrade to 3.0.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 6.5MavenPublished

    SSRF vulnerability due to missing permission check in Fortify on Demand Uploader Plugin

    CVE-2019-1003047 · GHSA-h3rg-4h5g-8fqg

    Affected
    • Maven org.jenkins-ci.plugins:fortify-on-demand-uploader <= 3.0.10
    Fixed in
    3.0.11· Vendor fix available
    Issue
    A missing permission check in Jenkins Fortify on Demand Uploader Plugin 3.0.10 and earlier allows attackers with Overall/Read permission to initiate a connection to an attacker-specified server.

    Recommended action: Upgrade to 3.0.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →