Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:flaky-test-handler

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.0MavenPublished

    Jenkins Flaky Test Handler Plugin stored cross-site scripting vulnerability

    CVE-2023-40342 · GHSA-hv48-hgp6-xpqf

    Affected
    • Maven org.jenkins-ci.plugins:flaky-test-handler < 1.2.3
    Fixed in
    1.2.3· Vendor fix available
    Issue
    Jenkins Flaky Test Handler Plugin 1.2.2 and earlier does not escape JUnit test contents when showing them on the Jenkins UI. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control JUnit report file contents. Flaky Test Handler Plugin 1.2.3 escapes JUnit test contents when showing them on the Jenkins UI.

    Recommended action: Upgrade to 1.2.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    CSRF vulnerability in Jenkins Flaky Test Handler Plugin

    CVE-2020-2237 · GHSA-vjf8-xw6c-wjhq

    Affected
    • Maven org.jenkins-ci.plugins:flaky-test-handler < 1.1.0
    Fixed in
    1.1.0· Vendor fix available
    Issue
    Flaky Test Handler Plugin 1.0.4 and earlier does not require POST requests for the "Deflake this build" feature, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to rebuild a project at a previous git revision where the tests were failing.

    Recommended action: Upgrade to 1.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.1MavenPublished

    XXE vulnerability in Jenkins Flaky Test Handler Plugin

    CVE-2022-28140 · GHSA-v4rr-65x6-g69f

    Affected
    • Maven org.jenkins-ci.plugins:flaky-test-handler < 1.2.2
    Fixed in
    1.2.2· Vendor fix available
    Issue
    Jenkins Flaky Test Handler Plugin 1.2.1 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.

    Recommended action: Upgrade to 1.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →