Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:depgraph-view

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Jenkins Dependency Graph Viewer Plugin contains Cross-site Scripting

    CVE-2019-10349 · GHSA-4wj7-rh5h-5qmr

    Affected
    • Maven org.jenkins-ci.plugins:depgraph-view <= 0.13
    Fixed in
    0.14· Vendor fix available
    Issue
    A stored cross site scripting vulnerability in Jenkins Dependency Graph Viewer Plugin 0.13 and earlier allowed attackers able to configure jobs in Jenkins to inject arbitrary HTML and JavaScript in the plugin-provided web pages in Jenkins.

    Recommended action: Upgrade to 0.14 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Jenkins Dependency Graph Viewer plugin vulnerable to missing permission checks

    CVE-2017-1000388 · GHSA-vhh3-mvc4-hhq6

    Affected
    • Maven org.jenkins-ci.plugins:depgraph-view <= 0.12
    Fixed in
    0.13· Vendor fix available
    Issue
    Jenkins Dependency Graph Viewer plugin 0.12 and earlier did not perform permission checks for the API endpoint that modifies the dependency graph, allowing anyone with Overall/Read permission to modify this data.

    Recommended action: Upgrade to 0.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →