Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:dependency-check-jenkins-plugin

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Jenkins OWASP Dependency-Check Plugin has stored XSS vulnerability

    CVE-2024-28153 · GHSA-9pp4-mx6x-xh36

    Affected
    • Maven org.jenkins-ci.plugins:dependency-check-jenkins-plugin < 5.4.6
    Fixed in
    5.4.6· Vendor fix available
    Issue
    Jenkins OWASP Dependency-Check Plugin 5.4.5 and earlier does not escape vulnerability metadata from Dependency-Check reports, resulting in a stored cross-site scripting (XSS) vulnerability.

    Recommended action: Upgrade to 5.4.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.1MavenPublished

    XXE vulnerability in Jenkins OWASP Dependency-Check Plugin

    CVE-2021-43577 · GHSA-mj5v-ggjc-48p5

    Affected
    • Maven org.jenkins-ci.plugins:dependency-check-jenkins-plugin <= 5.1.1
    Fixed in
    5.1.2· Vendor fix available
    Issue
    Jenkins OWASP Dependency-Check Plugin 5.1.1 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. This allows attackers able to control workspace contents to have Jenkins parse a crafted XML file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery.

    Recommended action: Upgrade to 5.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.1MavenPublished

    Persistent XSS vulnerability in Jenkins OWASP Dependency-Check Plugin

    CVE-2017-1000109 · GHSA-65cq-whr4-7c2v

    Affected
    • Maven org.jenkins-ci.plugins:dependency-check-jenkins-plugin <= 2.0.1.1
    Fixed in
    2.0.1.2· Vendor fix available
    Issue
    The custom Details view of the Static Analysis Utilities based OWASP Dependency-Check Plugin, was vulnerable to a persisted cross-site scripting vulnerability: Malicious users able to influence the input to this plugin could insert arbitrary HTML into this view.

    Recommended action: Upgrade to 2.0.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →