Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:database

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Missing permission checks in Jenkins Database Plugin

    CVE-2020-2242 · GHSA-hj36-v72x-cc6j

    Affected
    • Maven org.jenkins-ci.plugins:database <= 1.6
    Fixed in
    1.7· Vendor fix available
    Issue
    A missing permission check in Jenkins database Plugin 1.6 and earlier allows attackers with Overall/Read access to Jenkins to connect to an attacker-specified database server using attacker-specified credentials. Database Plugin 1.7 requires Overall/Administer permission for the affected form validation method.

    Recommended action: Upgrade to 1.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4MavenPublished

    CSRF vulnerability in Jenkins Database Plugin

    CVE-2020-2241 · GHSA-9rvw-7mx7-h53x

    Affected
    • Maven org.jenkins-ci.plugins:database <= 1.6
    Fixed in
    1.7· Vendor fix available
    Issue
    A cross-site request forgery (CSRF) vulnerability in Jenkins database Plugin 1.6 and earlier allows attackers to connect to an attacker-specified database server using attacker-specified credentials. Database Plugin 1.7 requires POST requests for the affected form validation method.

    Recommended action: Upgrade to 1.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.8MavenPublished

    CSRF vulnerability in Jenkins Database Plugin

    CVE-2020-2240 · GHSA-jf9j-hx2j-m9xh

    Affected
    • Maven org.jenkins-ci.plugins:database <= 1.6
    Fixed in
    1.7· Vendor fix available
    Issue
    Database Plugin 1.6 and earlier does not require POST requests for the database console, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to execute arbitrary SQL scripts. Database Plugin 1.7 removes the database console.

    Recommended action: Upgrade to 1.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →