Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
Jenkins CVS Plugin 2.16 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. This allows attackers able to control an agent process to have Jenkins parse a crafted changelog file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery. Jenkins CVS Plugin 2.17 disables external entity resolution for its XML parser.
Recommended action: Upgrade to 2.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
CVS Plugin 2.15 and earlier does not require POST requests in several HTTP endpoints, resulting in cross-site request forgery (CSRF) vulnerabilities. This allows attackers to create and manipulate tags, and to connect to an attacker-specified URL. CVS Plugin 2.16 now requires POST requests for the affected HTTP endpoints.
Recommended action: Upgrade to 2.16 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Jenkins CVS Plugin 2.19 and earlier does not escape the name and description of CVS Symbolic Name parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Recommended action: Upgrade to 2.19.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.