Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:cucumber-living-documentation

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Jenkins Cucumber Living Documentation Plugin Cross-site Scripting vulnerability

    CVE-2018-1000144 · GHSA-q7jx-r75r-hgj2

    Affected
    • Maven org.jenkins-ci.plugins:cucumber-living-documentation <= 1.0.12
    Fixed in
    1.1.0· Vendor fix available
    Issue
    A cross site scripting vulnerability exists in Jenkins Cucumber Living Documentation Plugin 1.0.12 and older in CukedoctorBaseAction#doDynamic that disables the Content-Security-Policy protection for archived artifacts and workspace files, allowing attackers able to control the content of these files to attack Jenkins users. This has been addressed in version 1.1.0 of the plugin, and it will now request that users change the Content-Security-Policy option in Jenkins.

    Recommended action: Upgrade to 1.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →