Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:crowd2

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    Jenkins Crowd 2 Integration Plugin server-side request forgery vulnerability

    CVE-2018-1000422 · GHSA-grmg-5q49-mqmf

    Affected
    • Maven org.jenkins-ci.plugins:crowd2 <= 2.0.0
    Fixed in
    2.0.1· Vendor fix available
    Issue
    An improper authorization vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java that allows attackers to have Jenkins perform a connection test, connecting to an attacker-specified server with attacker-specified credentials and connection settings.

    Recommended action: Upgrade to 2.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.8MavenPublished

    Jenkins Crowd 2 Integration Plugin stored credentials in plain text

    CVE-2018-1000423 · GHSA-cg6q-gp23-vwx8

    Affected
    • Maven org.jenkins-ci.plugins:crowd2 <= 2.0.0
    Fixed in
    2.0.1· Vendor fix available
    Issue
    An insufficiently protected credentials vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java, CrowdConfigurationService.java that allows attackers with local file system access to obtain the credentials used to connect to Crowd 2.

    Recommended action: Upgrade to 2.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →