Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:cppncss

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Reflected cross-site-scripting vulnerability in report URL of Jenkins CppNCSS Plugin

    CVE-2018-1000108 · GHSA-xgmh-rvpw-6498

    Affected
    • Maven org.jenkins-ci.plugins:cppncss <= 1.1
    Fixed in
    1.2· Vendor fix available
    Issue
    A cross-site scripting vulnerability exists in Jenkins CppNCSS Plugin 1.1 and earlier in AbstractProjectAction/index.jelly that allow an attacker to craft links to Jenkins URLs that run arbitrary JavaScript in the user's browser when accessed.

    Recommended action: Upgrade to 1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →