Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:coverity

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.7MavenPublished

    Jenkins Coverity Plugin has Insufficiently Protected Credentials

    CVE-2018-1000104 · GHSA-cghg-jcv6-4v5m

    Affected
    • Maven org.jenkins-ci.plugins:coverity <= 1.10.0
    Fixed in
    1.11.0· Vendor fix available
    Issue
    A plaintext storage of a password vulnerability exists in Jenkins Coverity Plugin 1.10.0 and earlier in CIMInstance.java that allows an attacker with local file system access or control of a Jenkins administrator's web browser (e.g. malicious extension) to retrieve the configured keystore and private key passwords. The Coverity Plugin 1.11.0 integrates with Credentials Plugin to store passwords, and automatically migrates existing passwords.

    Recommended action: Upgrade to 1.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →