Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:contrast-continuous-application-security

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Jenkins Contrast Continuous Application Security Plugin has a CSRF vulnerability

    CVE-2026-57298 · GHSA-6qc4-57v3-28rr

    Affected
    • Maven org.jenkins-ci.plugins:contrast-continuous-application-security < 3.12
    Fixed in
    3.12· Vendor fix available
    Issue
    Jenkins Contrast Continuous Application Security Plugin 3.11 and earlier does not perform a permission check in an HTTP endpoint that tests the connection to a Contrast TeamServer. This allows attackers with Overall/Read permission to connect to an attacker-specified URL using an attacker-specified username, API key, and service key. Additionally, this HTTP endpoint does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Contrast Continuous Application Security Plugin 3.12 requires Overall/Administer permission and POST requests to test the connection to a Contrast TeamServer.

    Recommended action: Upgrade to 3.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Jenkins Contrast Continuous Application Security Plugin missing permission checks

    CVE-2026-57299 · GHSA-8263-qv4g-vfxr

    Affected
    • Maven org.jenkins-ci.plugins:contrast-continuous-application-security < 3.12
    Fixed in
    3.12· Vendor fix available
    Issue
    Jenkins Contrast Continuous Application Security Plugin 3.11 and earlier does not perform permission checks in several HTTP endpoints that fill list box options with the names of the configured Contrast metadata. This allows attackers with Overall/Read permission to enumerate the names of configured Contrast metadata. Contrast Continuous Application Security Plugin 3.12 requires the appropriate permission to enumerate the configured Contrast metadata.

    Recommended action: Upgrade to 3.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 4.3MavenPublished

    Jenkins Contrast Continuous Application Security Plugin has a missing permission check

    CVE-2026-57297 · GHSA-p44q-fmwr-jqr7

    Affected
    • Maven org.jenkins-ci.plugins:contrast-continuous-application-security < 3.12
    Fixed in
    3.12· Vendor fix available
    Issue
    Jenkins Contrast Continuous Application Security Plugin 3.11 and earlier does not perform a permission check in an HTTP endpoint that tests the connection to a Contrast TeamServer. This allows attackers with Overall/Read permission to connect to an attacker-specified URL using an attacker-specified username, API key, and service key. Additionally, this HTTP endpoint does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Contrast Continuous Application Security Plugin 3.12 requires Overall/Administer permission and POST requests to test the connection to a Contrast TeamServer.

    Recommended action: Upgrade to 3.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5MavenPublished

    Stored XSS vulnerability in Jenkins Contrast Continuous Application Security Plugin

    CVE-2022-43420 · GHSA-hvcr-927w-qcvq

    Affected
    • Maven org.jenkins-ci.plugins:contrast-continuous-application-security <= 3.9
    Fixed in
    3.10· Vendor fix available
    Issue
    Contrast Continuous Application Security Plugin 3.9 and earlier does not escape data returned from the Contrast service when generating a report. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control or modify Contrast service API responses. Contrast Continuous Application Security Plugin 3.10 escapes the affected data.

    Recommended action: Upgrade to 3.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →