Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:confluence-publisher

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Server-Side Request Forgery (SSRF) in Jenkins Confluence Publisher Plugin

    CVE-2018-1999039 · GHSA-5339-9974-hqj9

    Affected
    • Maven org.jenkins-ci.plugins:confluence-publisher <= 2.0.1
    Fixed in
    2.0.2· Vendor fix available
    Issue
    A server-side request forgery vulnerability exists in Jenkins Confluence Publisher Plugin 2.0.1 and earlier in ConfluenceSite.java that allows attackers to have Jenkins submit login requests to an attacker-specified Confluence server URL with attacker specified credentials.

    Recommended action: Upgrade to 2.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →