High, CVSS 8.8MavenPublished
CSRF vulnerability in Jenkins Configuration Slicing Plugin
CVE-2021-21617 · GHSA-42mm-x828-56c7
- Affected
- Maven org.jenkins-ci.plugins:configurationslicing <= 1.51
- Fixed in
- 1.52· Vendor fix available
- Issue
- Jenkins Configuration Slicing Plugin 1.51 and earlier does not require POST requests for the form submission endpoint reconfiguring slices, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to apply different slice configurations to attacker-specified jobs. Jenkins Configuration Slicing Plugin 1.52 requires POST requests for the affected HTTP endpoint.
Recommended action: Upgrade to 1.52 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.