Medium, CVSS 5.4MavenPublished
Stored XSS vulnerability in Jenkins Compact Columns Plugin
CVE-2020-2195 · GHSA-x68x-wvm2-hqc8
- Affected
- Maven org.jenkins-ci.plugins:compact-columns < 1.12
- Fixed in
- 1.12· Vendor fix available
- Issue
- Compact Columns Plugin 1.11 and earlier displays the unprocessed job description in tooltips. This results in a stored cross-site scripting vulnerability that can be exploited by users with Job/Configure permission. Compact Columns Plugin 1.12 applies the configured markup formatter to the job description shown in tooltips.
Recommended action: Upgrade to 1.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.