Medium, CVSS 4.3MavenPublished
Jenkins Cloud Foundry Plugin vulnerable to exposure of sensitive information
CVE-2019-1003025 · GHSA-2mh9-wpgv-7xr8
- Affected
- Maven org.jenkins-ci.plugins:cloudfoundry <= 2.3.1
- Fixed in
- 2.3.2· Vendor fix available
- Issue
- \Jenkins Cloud Foundry Plugin did not perform permission checks on a method implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, this form validation method did not require POST requests, resulting in a cross-site request forgery vulnerability. This form validation method now requires POST requests and Overall/Administer (for global configuration) or Item/Configure permissions (for job configuration).
Recommended action: Upgrade to 2.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.