Medium, CVSS 5.4MavenPublished
Jenkins Build Environment Plugin vulnerable to Cross-site Scripting
CVE-2019-10395 · GHSA-88qj-3q6h-8m5q
- Affected
- Maven org.jenkins-ci.plugins:build-environment < 1.7
- Fixed in
- 1.7· Vendor fix available
- Issue
- Build Environment Plugin did not escape values of environment variables shown on its views. This resulted in a cross-site scripting vulnerability exploitable by attackers able to control the values of build environment variables, typically users with Job/Configure or Job/Build permission. Jenkins applies the missing escaping by default since 2.146 and LTS 2.138.2, so newer Jenkins releases are not affected by this vulnerability. Build Environment Plugin now escapes all variables displayed in its views.
Recommended action: Upgrade to 1.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.