Medium, CVSS 5.4MavenPublished
Stored XSS vulnerability in Jenkins brakeman Plugin
CVE-2020-2122 · GHSA-7q9r-vhg2-789w
- Affected
- Maven org.jenkins-ci.plugins:brakeman < 0.13
- Fixed in
- 0.13· Vendor fix available
- Issue
- brakeman Plugin 0.12 and earlier did not escape values received from parsed JSON files when rendering them, resulting in a stored cross-site scripting vulnerability. This vulnerability can be exploited by users able to control the Brakeman post-build step input data.\n\nbrakeman Plugin 0.13 escape affected values from the parsed file as they are recorded. This fix is only applied to newly recorded data after a fixed version of the plugin is installed; historical data may still contain unsafe values.
Recommended action: Upgrade to 0.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.