High, CVSS 8.0MavenPublished
Stored XSS vulnerability in Jenkins Authorize Project Plugin
CVE-2024-52552 · GHSA-8886-8v27-85j8
- Affected
- Maven org.jenkins-ci.plugins:authorize-project < 1.8.0
- Fixed in
- 1.8.0· Vendor fix available
- Issue
- Jenkins Authorize Project Plugin 1.7.2 and earlier evaluates a string containing the job name with JavaScript on the Authorization view, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Authorize Project Plugin 1.8.0 no longer evaluates a string containing the job name with JavaScript on the Authorization view.
Recommended action: Upgrade to 1.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.