High, CVSS 8.0MavenPublished
Jenkins Applitools Eyes Plugin vulnerable to XSS through its Build page
CVE-2025-53658 · GHSA-j4wf-9gx8-63f8
- Affected
- Maven org.jenkins-ci.plugins:applitools-eyes <= 1.16.5
- Fixed in
- 1.16.6· Vendor fix available
- Issue
- Jenkins Applitools Eyes Plugin 1.16.5 and earlier does not escape the Applitools URL on the build page. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Applitools Eyes Plugin 1.16.6 rejects Applitools URLs that contain HTML metacharacters.
Recommended action: Upgrade to 1.16.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.