High, CVSS 8.0MavenPublished
Cross-site Scripting in Jenkins Application Detector Plugin
CVE-2022-30960 · GHSA-6wh8-mr6f-6cx2
- Affected
- Maven org.jenkins-ci.plugins:app-detector < 1.0.9
- Fixed in
- 1.0.9· Vendor fix available
- Issue
- Jenkins Application Detector Plugin 1.0.8 and earlier does not escape the name of Chois Application Version parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Recommended action: Upgrade to 1.0.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.