Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:anchore-container-scanner

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.0MavenPublished

    Jenkins Anchore Container Image Scanner Plugin vulnerable to cross site scripting

    CVE-2022-41225 · GHSA-f2j5-w76m-3rqh

    Affected
    • Maven org.jenkins-ci.plugins:anchore-container-scanner <= 1.0.24
    Fixed in
    1.0.25· Vendor fix available
    Issue
    Jenkins Anchore Container Image Scanner Plugin 1.0.24 and earlier does not escape content provided by the Anchore engine API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control API responses by Anchore engine.

    Recommended action: Upgrade to 1.0.25 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.5MavenPublished

    Jenkins Anchore Container Scanner Plugin vulnerable to Insufficiently Protected Credentials

    CVE-2019-16542 · GHSA-jg29-c2qj-wpm3

    Affected
    • Maven org.jenkins-ci.plugins:anchore-container-scanner < 1.0.20
    Fixed in
    1.0.20· Vendor fix available
    Issue
    Jenkins Anchore Container Image Scanner Plugin 1.0.19 and earlier stores credentials unencrypted in job config.xml files on the Jenkins master where they can be viewed by users with Extended Read permission, or access to the master file system. The credential being stored was a service password for the Anchore.io service. As the affected functionality has been deprecated, and the affected Anchore.io service has been shut down in late 2018, the affected feature has been removed.

    Recommended action: Upgrade to 1.0.20 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.5MavenPublished

    Exposure of sensitive information in Anchore Container Image Scanner Jenkins Plugin

    CVE-2018-1999033 · GHSA-w9v7-7mq5-p27c

    Affected
    • Maven org.jenkins-ci.plugins:anchore-container-scanner < 1.0.17
    Fixed in
    1.0.17· Vendor fix available
    Issue
    An exposure of sensitive information vulnerability exists in Jenkins Anchore Container Image Scanner Plugin 10.16 and earlier in AnchoreBuilder.java that allows attackers with Item/ExtendedRead permission or file system access to the Jenkins master to obtain the password stored in this plugin's configuration.

    Recommended action: Upgrade to 1.0.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →