Skip to content

← Public intelligence

Maven package

org.jenkins-ci.main:maven-plugin

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    Maven Integration Plugin did not mask sensitive values in module build logs

    CVE-2019-10358 · GHSA-hr96-qfvm-52r6

    Affected
    • Maven org.jenkins-ci.main:maven-plugin <= 3.3
    Fixed in
    3.4· Vendor fix available
    Issue
    Jenkins Maven Integration Plugin 3.3 and earlier did not apply build log decorators to module builds, potentially revealing sensitive build variables in the build log.

    Recommended action: Upgrade to 3.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.9MavenPublished

    MitM on Jenkins Maven Plugin

    CVE-2017-1000397 · GHSA-qhxw-54m9-6wwc

    Affected
    • Maven org.jenkins-ci.main:maven-plugin < 3.0
    Fixed in
    3.0· Vendor fix available
    Issue
    Jenkins Maven Plugin 2.17 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. Maven Plugin 3.0 no longer has a dependency on commons-httpclient.

    Recommended action: Upgrade to 3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →