Medium, CVSS 4.3MavenPublished
Cross-Site Request Forgery in Jenkins
CVE-2022-20612 · GHSA-p92q-7fhh-mq35
- Affected
- Maven org.jenkins-ci.main:jenkins-core < 2.319.2; >= 2.320, < 2.330
- Fixed in
- 2.3302.319.2· Vendor fix available
- Issue
- Jenkins 2.329 and earlier, LTS 2.319.1 and earlier does not require POST requests for the HTTP endpoint handling manual build requests when no security realm is set, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to trigger build of job without parameters. Jenkins 2.330, LTS 2.319.2 requires POST requests for the affected HTTP endpoint.
Recommended action: Upgrade to 2.330 or 2.319.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.