Medium, CVSS 6.1MavenPublished
Cross site scripting vulnerability in update-center2
CVE-2023-27905 · GHSA-pqg3-xfx2-fmqp
- Affected
- Maven org.jenkins-ci:update-center2 >= 3.13, < 3.15
- Fixed in
- 3.15· Vendor fix available
- Issue
- Jenkins update-center2 3.13 and 3.14 renders the required Jenkins core version on plugin download index pages without sanitization, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide a plugin for hosting.
Recommended action: Upgrade to 3.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.