Skip to content

← Public intelligence

Maven package

org.jeecgframework.boot:jeecg-boot-common

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    SQL injection in JeecgBoot

    CVE-2024-57606 · GHSA-wfpm-qchc-6cf9

    Affected
    • Maven org.jeecgframework.boot:jeecg-boot-common <= 3.7.2
    Fixed in
    3.7.3· Vendor fix available
    Issue
    SQL injection vulnerability in Beijing Guoju Information Technology Co., Ltd JeecgBoot v.3.7.2 allows a remote attacker to obtain sensitive information via the getTotalData component.

    Recommended action: Upgrade to 3.7.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8MavenPublished

    SQL injection in jeecgboot

    CVE-2023-40989 · GHSA-rwhx-6hx7-pqc8

    Affected
    • Maven org.jeecgframework.boot:jeecg-boot-common <= 3.5.3
    Fixed in
    3.6.0· Vendor fix available
    Issue
    SQL injection vulnerbility in jeecgboot jeecg-boot v 3.0, 3.5.3 that allows a remote attacker to execute arbitrary code via a crafted request to the report/jeecgboot/jmreport/queryFieldBySql component.

    Recommended action: Upgrade to 3.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8MavenPublished

    SQL injection in jeecg-boot

    CVE-2023-38992 · GHSA-wp6c-29r3-jqw9

    Affected
    • Maven org.jeecgframework.boot:jeecg-boot-common < 3.5.3
    Fixed in
    3.5.3· Vendor fix available
    Issue
    jeecg-boot v3.5.1 was discovered to contain a SQL injection vulnerability via the title parameter at /sys/dict/loadTreeData.

    Recommended action: Upgrade to 3.5.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →