Skip to content

← Public intelligence

Maven package

org.jeecgframework.boot:jeecg-boot-base

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Cross-site Scripting in jeecg-boot

    CVE-2021-44585 · GHSA-q448-6c3m-cxmj

    Affected
    • Maven org.jeecgframework.boot:jeecg-boot-base <= 3.0
    Fixed in
    3.1.0· Vendor fix available
    Issue
    jeecg-boot is a code generator. A Cross Site Scripting (XSS) vulnerabilitiy exists in jeecg-boot 3.0 in /jeecg-boot/jmreport/view with a mouseover event.

    Recommended action: Upgrade to 3.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →