Skip to content

← Public intelligence

Maven package

org.grails:grails-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1MavenPublished

    Incorrect Resource Transfer Between Spheres in Grails

    CVE-2019-12728 · GHSA-pmxf-4v8c-rwr7

    Affected
    • Maven org.grails:grails-core < 3.3.10
    Fixed in
    3.3.10· Vendor fix available
    Issue
    Grails before 3.3.10 used cleartext HTTP to resolve the SDKMan notification service. NOTE: users' apps were not resolving dependencies over cleartext HTTP.

    Recommended action: Upgrade to 3.3.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1MavenPublished

    Stored Cross Site Scripting in Grails Fields Plugin

    CVE-2018-1000529 · GHSA-q25j-gcmv-5qpp

    Affected
    • Maven org.grails:grails-core < 3.3.6
    Fixed in
    3.3.6· Vendor fix available
    Issue
    Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in using the display tag that can result in XSS. This vulnerability has been fixed in version 2.2.8.

    Recommended action: Upgrade to 3.3.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →