Skip to content

← Public intelligence

Maven package

org.gradle:gradle-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Use of a weak cryptographic algorithm in Gradle

    CVE-2019-16370 · GHSA-hhr2-f668-ff2w

    Affected
    • Maven org.gradle:gradle-core < 6.0
    Fixed in
    6.0· Vendor fix available
    Issue
    The PGP signing plugin in Gradle before 6.0 relies on the SHA-1 algorithm, which might allow an attacker to replace an artifact with a different one that has the same SHA-1 message digest, a related issue to CVE-2005-4900.

    Recommended action: Upgrade to 6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.9MavenPublished

    Insecure transport protocol in Gradle

    CVE-2019-11065 · GHSA-pprq-4488-wgqx

    Affected
    • Maven org.gradle:gradle-core >= 1.4, < 5.4.0
    Fixed in
    5.4.0· Vendor fix available
    Issue
    Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.

    Recommended action: Upgrade to 5.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →