Medium, CVSS 6.8MavenPublished
Eclipse Glassfish remote code execution issue
CVE-2023-5763 · GHSA-2mw4-wj8c-7f93
- Affected
- Maven org.glassfish.main.orb:orb-connector >= 5.0.0, < 7.0.0
- Fixed in
- 7.0.0· Vendor fix available
- Issue
- In Eclipse Glassfish 5 or 6, running with old versions of JDK (lower than 6u211, or < 7u201, or < 8u191), allows remote attackers to load malicious code on the server via access to insecure ORB listeners.
Recommended action: Upgrade to 7.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.