Medium, CVSS 6.5MavenPublished
Generation of Error Message Containing Sensitive Information in Elasticsearch
CVE-2021-22145 · GHSA-q394-h7f5-7f44
- Affected
- Maven org.elasticsearch.client:elasticsearch-rest-client >= 7.10.0, <= 7.13.3
- Fixed in
- 7.13.4· Vendor fix available
- Issue
- A memory disclosure vulnerability was identified in Elasticsearch 7.10.0 to 7.13.3 error reporting. A user with the ability to submit arbitrary queries to Elasticsearch could submit a malformed query that would result in an error message returned containing previously used portions of a data buffer. This buffer could contain sensitive information such as Elasticsearch documents or authentication details.
Recommended action: Upgrade to 7.13.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.