High, CVSS 7.4MavenPublished
Cross-site Scripting (XSS) in CrafterCMS
CVE-2023-4136 · GHSA-jfm4-3vv3-fm4v
- Affected
- Maven org.craftercms:crafter-engine >= 4.0.0, < 4.0.3; >= 3.1.0, < 3.1.28
- Fixed in
- 3.1.284.0.3· Vendor fix available
- Issue
- Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CrafterCMS Engine on Windows, MacOS, Linux, x86, ARM, 64 bit allows Reflected XSS.This issue affects CrafterCMS: from 4.0.0 through 4.0.2, from 3.1.0 through 3.1.27.
Recommended action: Upgrade to 4.0.3 or 3.1.28 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.